Information Technology Reference
In-Depth Information
Example 10-10 Route Map to Filter Routes for Redistribution
router eigrp 100
redistribute rip route-map rip-to-eigrp
!
access-list 50 permit 3.0.0.0
access-list 50 permit 4.0.0.0
!
route-map rip-to-eigrp permit 10
match ip address 50
PBR
Policy routing can modify the next-hop address or mark packets to receive differential service.
Routing is based on destination addresses; PBR is commonly used to modify the next-hop IP
address, which is based on the source address. More recently, PBR has been implemented to
mark the IP precedence bits in outbound IP packets so that they comply with Quality of Service
(QoS) policies.
PBR is configured using route maps. In Example 10-11, the next-hop IP address is modified for
all inbound packets on Ethernet 0 that match access list 10 or 20. The next hop is modified to
192.168.100.1 for any packet from network 192.168.1.0/24. The next hop is modified to
192.168.100.2 for any packet from network 192.168.2.0/24. Packets from other sources use the
next hop, which is determined by the routing protocol.
Example 10-11 Policy-Based Routing Configuration Example
access-list 10 permit 192.168.1.0
access-list 20 permit 192.168.2.0
!
interface ethernet 0
ip policy route-map nexthop
!
route-map nexthop permit 10
match ip address 10
set ip next-hop 192.168.100.1
!
route-map nexthop permit 20
match ip address 20
set ip next-hop 192.168.100.2
!
route-map nexthop permit 30
Search WWH ::




Custom Search