Information Technology Reference
In-Depth Information
Example 11-19 Customer Router Configuration
hostname Customer
!
ip multicast-routing
!
interface Loopback0
ip address 10.1.0.1 255.255.255.255
!
interface Ethernet0/0
ip address 10.100.1.1 255.255.255.0
ip pim sparse-mode
!
interface Serial2/0
ip address 10.1.1.1 255.255.255.252
ip pim sparse-mode
!
ip pim rp-address 10.1.0.1
ip msdp peer 10.1.1.2 connect-source Serial2/0
ip msdp default-peer 10.1.1.2
The provider configuration is shown in Example 11-20.
Example 11-20 Provider Router Configuration
hostname Provider
!
ip multicast-routing
!
interface Loopback0
ip address 100.1.0.2 255.255.255.255
!
interface Serial2/0
ip address 10.1.1.2 255.255.255.252
ip pim sparse-mode
no fair-queue
!
!
router bgp 100
...
address-family ipv4 multicast
...
network 10.100.1.0 mask 255.255.255.0
network 10.1.0.1 mask 255.255.255.255
!
ip pim rp-address 100.1.0.2
ip msdp peer 10.1.1.1 connect-source Serial2/0
ip route 10.1.0.1 255.255.255.255 10.1.1.1
ip route 10.100.1.0 255.255.255.0 10.1.1.1
!
Search WWH ::




Custom Search