Information Technology Reference
In-Depth Information
Example 5-38 Final Configuration for R2
hostname R2
!
interface Loopback0
ip address 172.16.2.1 255.255.255.0
!
interface Ethernet0/0
ip address 10.1.1.2 255.255.255.0
!
interface Ethernet1/0
ip address 10.1.101.2 255.255.255.0
!
router eigrp 100
redistribute bgp 65101 route-map DEFAULT_ROUTE
passive-interface Ethernet0/0
network 10.0.0.0
network 172.16.0.0
default-metric 10000 100 255 1 1500
no auto-summary
no eigrp log-neighbor-changes
!
router bgp 65101
no synchronization
bgp log-neighbor-changes
redistribute eigrp 100 route-map DENY_DEFAULT
neighbor 10.1.1.4 remote-as 65100
neighbor 10.1.1.4 route-map SET_MED out
neighbor 172.16.1.1 remote-as 65101
neighbor 172.16.1.1 update-source Loopback0
no auto-summary
bgp bestpath compare-routerid
!
ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0
ip prefix-list DEFAULT seq 10 deny 0.0.0.0/0 le 32
ip prefix-list NO_DEFAULT seq 5 deny 0.0.0.0/0
ip prefix-list NO_DEFAULT seq 10 permit 0.0.0.0/0 le 32
!
route-map DENY_DEFAULT permit 10
match ip address prefix-list NO_DEFAULT
!
route-map DEFAULT_ROUTE permit 10
match ip address prefix-list DEFAULT
!
route-map SET_MED permit 10
set metric-type internal
!
Search WWH ::




Custom Search